Adobe - What to do when the Creative Cloud Desktop Application says apps are Not Compatible


Issue

The Adobe Creative Cloud Desktop Application reports that some apps are "Not Compatible."

Environment

Classic-CoreImage

  • Windows 10
  • Windows 11

Intune-CoreImage

  • Windows 10
  • Windows 11

Cause

Many Michigan Medicine CoreImage devices now run Windows 11 and should be fully compatible with Adobe applications. However, certain devices may still be running an older version of Windows for unrelated workflow or software compatibility reasons. If you see a prompt like the one below, your device is not running a version of Windows that is compatible with the Adobe product you're trying to install.

Resolution

The screenshots in these instructions reference Photoshop; however, other applications can be addressed using the same steps.

  1. Find the latest version in the grid of applications that is still compatible.

  2. Click Install.


  3. If you do not see the option to install a compatible version, click the . . . (three dots) next to the Not Compatible warning


  4. Select Other versions to see the list of previous versions you can install.

  5. Select and install the version you want.

 

Once your CoreImage device is upgraded to the current version of Windows 11, you can upgrade these applications to their latest versions.